#1 2017-12-17 10:54:21

rustfansite
Endora uživatel
Registrován: 1970-01-01
Příspěvky: 9

Nezabežpečené

Zdravím, web mi ukazuje vaše pripojenie je nezabezpečené, mám domenu 2 a pridaný alias ( free domena), jak to spravím ? vid obrazek https://ctrlv.cz/95aL

Upravil rustfansite (2017-12-17 10:56:43)

Offline

#2 2017-12-18 09:34:18

TomasEndora
Podpora
Registrován: 2017-09-05
Příspěvky: 32

Re: Nezabežpečené

Dobrý den,
tuto hlášku vidíte proto, že na svých stránkách nepoužíváte HTTPS protokol, který při komunikaci data šifruje, na rozdíl od běžného HTTP. Prohlížeče nyní tuto hlášku vypisují, pokud nedetekují HTTPS protokol.
K tomu, aby Vaše stránky běžely pod HTTPS, musíte mít vygenerovaný SSL certifikát pro svou doménu. Pro tento případ nabízí Endora zdarma SSL certifikát od Let's Encrypt. Více v naší nápovědě zde -> https://www.endora.cz/vlastnosti/https- … ing-endora
a zde -> https://www.endora.cz/podpora/napoveda/ … certifikat

Offline

#3 2017-12-19 08:21:44

rustfansite
Endora uživatel
Registrován: 1970-01-01
Příspěvky: 9

Re: Nezabežpečené

teraz sa mi zobrazuje neplatný certifikát, po odstránení mi to zničilo web.... jak to teraz opravím / odstránim ?

Upravil rustfansite (2017-12-19 08:24:46)

Offline

#4 2017-12-19 10:20:21

TomasEndora
Podpora
Registrován: 2017-09-05
Příspěvky: 32

Re: Nezabežpečené

Pokud si přejete certifikát odstranit, stačí v administraci Endory kliknout na sekci -> Webové prostory -> vybrat svůj prostor -> v sekci HTTPS certifikát zrušit.
Pokud jste si své stránky uvedl do nefunkčního stavu, doporučuji nahrání zálohy z data, kdy stránky byly ještě funkční. To provedete opět v sekci Webové prostory -> vyberete svůj prostor -> sekce Zálohy. Zde budou dostupné zálohy pro Váš webový prostor

Offline

#5 2017-12-19 10:55:38

rustfansite
Endora uživatel
Registrován: 1970-01-01
Příspěvky: 9

Re: Nezabežpečené

tak som aj spravil, napriek tomu mi stale vyskakuje okno o neplatnom certifikate

Offline

#6 2017-12-19 14:11:23

JF
Endora rádce
Místo: Plzeň
Registrován: 2010-06-22
Příspěvky: 10,240
Web

Re: Nezabežpečené

Vaša stránka sa mi korektne načíta, neevidujem na nej vynútenie SSL s neplatným certifikátom.


Ján Fačkovec - Helpdesk Endora.cz
- Email: jan.fackovec(zavináč)endora.cz
- Web: www.endora.cz
Zlepšite si stránku českým validátorom!

Offline

#7 2017-12-19 14:57:47

rustfansite
Endora uživatel
Registrován: 1970-01-01
Příspěvky: 9

Re: Nezabežpečené

mne nie vid screen, jak to mám odstraníť, aby sa mi to nezobrazovalo ?
https://ctrlv.cz/mxbr
https://ctrlv.cz/j5vy

Upravil rustfansite (2017-12-20 08:57:13)

Offline

#8 2017-12-20 13:19:11

JF
Endora rádce
Místo: Plzeň
Registrován: 2010-06-22
Příspěvky: 10,240
Web

Re: Nezabežpečené

Ideálne premazať cache vášho prehliadača/počítača aby zabudol presmerovanie na ssl.
Prípadne si môžete zdarma vygenerovať certifikát k vašej doméne. Takto sa pri prístupe cez https vloží defaultný certifikát vystavený pre stránku endora.cz


Ján Fačkovec - Helpdesk Endora.cz
- Email: jan.fackovec(zavináč)endora.cz
- Web: www.endora.cz
Zlepšite si stránku českým validátorom!

Offline

#9 2018-06-28 11:35:37

karelsvancara
Endora uživatel
Registrován: 2013-05-29
Příspěvky: 6

Re: Nezabežpečené

Dobrý den,

mám stejný problém. Mám u Vás 2 stránky:

https://www.sdg.cz/ běžící na wordpressu, tam jsem našel, že si mám stáhnout plugin really-simple-ssl.3.0.2.zip. To zkusím večer. Zatím mi to červeně hlásí, že spojení není zabezpečené.

Pak mám ještě stránku https://pratelskedary.cz/ běžící na prestashopu, ale zde v konfiguraci - hlavní - Povolit SSL - Povolit SSL Před povolením SSL klikněte prosím sem pro použití HTTPS protokolu. Po kliknutí to nic nedělá. Dá se to udělat nějak manuálně?

Hrozí mi nějaké riziko poničení stránek, při přechodu na https:// ?

Děkuji.

Offline

#10 2018-06-30 17:55:38

karelsvancara
Endora uživatel
Registrován: 2013-05-29
Příspěvky: 6

Re: Nezabežpečené

Řešení funguje výborně pro Wordpress. Jen je potřeba  po stáhnutí při instalací  Really Simple SSL pluginu odškrtnout Enable Javascript redirection to SSL, jinak Vás to potom nepustí do wp-admin. Pokud už se zablokujete je potřeba ve wp-config.php napsat /* pod řádek Begin Really Simple SSL Load balancing fix. Pak se lze dostat do wp-admin back office a odškrtnout pole. Pak je nutné smazat /*a front office i back office by měly být v pořádku.

S Prestahopem je, ale problém. Po kliknutí na záložku Konfigurace => Hlavní. V případě, že přistupujete přes protokol HTTP tak u volby Povolit SSL uvidíte odkaz Před povolením SSL klikněte prosím sem pro použití HTTPS protokolu. Ten bohužel nefunguje a zůstáváte stále na stejné stránce. Je potřeba to upravit manuálně hodnotu přes administraci MySQL databáze - MyISAM. V tabulce ps_configuration PS_SSL_ENABLED musíte hodnotu změnit z 0 na 1. Potom v Prestashop back office zaškrtněte i volbu Vynutit SSL pro všechny stránky. Pak .htaccess přidat:
RewriteEngine on
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTP_USER_AGENT} !(BlackBerry)
RewriteCond %{HTTP_USER_AGENT} !(Windows\sNT\s5\.[12])
RewriteCond %{HTTP_HOST} ^(www\.)?nazev-domeny.koncovka
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L]
Nyní nastane problém, že stránky jsou buď bílé, nebo zkončí na chybě mnoha přesměrování. Zkusil jsem změnit SEO URL v back office na https, ale to nepomohlo.

Offline

#11 2018-07-08 14:31:15

karelsvancara
Endora uživatel
Registrován: 2013-05-29
Příspěvky: 6

Re: Nezabežpečené

Nakonec mi pomohli z podpory tím, že přidali do settings.inc.php radky:

if( isset($_SERVER['HTTP_X_FORWARDED_PROTO']) ) {
$_SERVER['HTTPS'] = 'on';
$_SERVER['SERVER_PORT'] = 443;
}

a nasledne aktivovali SSL pres backoffice.

Offline

Zápatí

Založeno na FluxBB | CZ a SK